anything
1-800-401-2474 | support@airnavsystems.com
Forum| About| Support| Contact
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: rbfeeder unable to locate error  (Read 680 times)

0 Members and 1 Guest are viewing this topic.

jstutman

  • New Member
  • *
  • Posts: 5
rbfeeder unable to locate error
« on: July 04, 2019, 02:30:13 AM »
Following these instructions.

radarbox24.com/raspberry-pi/guide

after I run the command


sudo bash -c "$(wget -O - rb24/inst_rbfeeder.sh)"


I get the following error:

E: Unable to locate package rbfeeder

imgur./a/pRCwUpX

*I apparently have to edit all of the url's cause it thinks I am spam.

jstutman

  • New Member
  • *
  • Posts: 5
Re: rbfeeder unable to locate error
« Reply #1 on: July 04, 2019, 02:30:59 AM »
limk to imgur screenshot of error

https://imgur.com/a/pRCwUpX

abcd567

  • Sr. Member
  • ****
  • Posts: 258
  • CYYZ - Toronto
Re: rbfeeder unable to locate error
« Reply #2 on: July 04, 2019, 04:16:11 AM »
Code: [Select]
sudo apt-get update
sudo apt-get install rbfeeder

After last command it may ask  "...not authenticated. Install without authentication?".
Press y key (for yes) and then press Enter key.

When installtion completes, gives these two commands
Code: [Select]
sudo systemctl restart rbfeeder
sudo systemctl status rbfeeder

« Last Edit: July 04, 2019, 04:44:13 AM by abcd567 »

jstutman

  • New Member
  • *
  • Posts: 5
Re: rbfeeder unable to locate error
« Reply #3 on: July 04, 2019, 04:42:48 AM »
Thanks. I had to install apt-transport-https first but then following your additional commands got me all taken care of.

Next issue is trying to install MLAT as the station says it is not configured.

https://www.radarbox24.com/stations/EXTRPI001115

This is the error I get when trying to install the mlay-client

https://imgur.com/a/floaqtf

also MLAT is configured for piaware.
https://flightaware.com/adsb/stats/user/jstutman#stats-41947
« Last Edit: July 04, 2019, 04:51:29 AM by jstutman »

wiedehopf

  • Jr. Member
  • **
  • Posts: 53
Re: rbfeeder unable to locate error
« Reply #4 on: July 04, 2019, 06:10:07 AM »
Show

cat /etc/os-release | grep -i pretty

Probably you are on an older system.
So you can probably get the current piaware sd-card image and fix it like that.

Or try:
sudo apt update
sudo apt dist-upgrade

That may fix the problem.


Or you can compile the mlat-client from source:
https://github.com/mutability/mlat-client

abcd567

  • Sr. Member
  • ****
  • Posts: 258
  • CYYZ - Toronto
Re: rbfeeder unable to locate error
« Reply #5 on: July 04, 2019, 07:47:01 AM »

This is the error I get when trying to install the mlay-client

https://imgur.com/a/floaqtf


I got exactly same problem on Raspbian Buster. Seems you are also using Raspbian Buster. Here is the solution I posted yesterday:

https://www.airnavsystems.com/forum/index.php?topic=101771.msg407051#msg407051

wiedehopf

  • Jr. Member
  • **
  • Posts: 53
Re: rbfeeder unable to locate error
« Reply #6 on: July 04, 2019, 02:45:48 PM »
Read the message more closely, his python version is 3.4, but mlat-client needs >= 3.5
Your python version is 3.7 but mlat client needs < 3.6

So in essence the precompiled version needs version 3.5

Basically you need to either run Raspbian Stretch or compile mlat-client yourself.