anything

AirNav Systems Forum

Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: MLAT  (Read 8114 times)

0 Members and 2 Guests are viewing this topic.

wiedehopf

  • Jr. Member
  • **
  • Posts: 54
MLAT
« on: March 27, 2019, 04:45:09 PM »
I didn't even know you need to install the package mlat-client on the RPi.

This is new i presume as it's not in the install script?

abcd567

  • Sr. Member
  • ****
  • Posts: 260
  • CYYZ - Toronto
Re: MLAT
« Reply #1 on: March 27, 2019, 05:03:46 PM »
STEP-1: Update & install mlat-client
Code: [Select]
sudo apt-get update
sudo apt-get install mlat-client -y
sudo reboot

NOTE:
Above method to install mlat-client may fail for Raspbian Buster. If this happens, then use method given in the following post:
https://www.airnavsystems.com/forum/index.php?topic=101771.msg407051#msg407051

STEP-2: Edit file /etc/rbfeeder.ini, and ADD lines shown in RED to enable mlat
Note:
Use actual values in place of:
xx.xxxxxx (latitude)
yy.yyyyyy (longitude)
zzz  (antenna height, in meters, above sea level)

Code: [Select]
sudo nano /etc/rbfeeder.ini


Quote
[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
sn=EXTRPI000nnn
lat=xx.xxxxxx
lon=yy.yyyyyy
alt=zzz


[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true


STEP-3: Restart rbfeeder
Code: [Select]
sudo systemctl restart rbfeeder

STEP-4: Check page: 
radarbox24.com/stations/EXTRPInnnnnn
(replace nnnnnn by your station number)
IF MLAT IS OK, it will be like attached screenshot.

========================================================
Alternate to STEP-2 (all other steps remain same)
========================================================
Instead of editing file /etc/rbfeeder.ini and adding lat, lon & alt manually, you can set these from RB24 web interface as shown below:
1. Go to following web page (replace xxxxxx by your station number)
radarbox24.com/stations/EXTRPIxxxxxx
2. Login to your account.
3. After login, on top left of web page, at the end of the line showing your city, Edit will appear, as shown by red arrow in attached screenshot.
Click Edit. This will open lat/lon setting box. Set your lat, lon & alt there.
4. Go to STEP-3 (restart rbfeeder)



« Last Edit: July 16, 2019, 09:49:36 PM by abcd567 »

wiedehopf

  • Jr. Member
  • **
  • Posts: 54
Re: MLAT
« Reply #2 on: March 27, 2019, 05:12:57 PM »
If you provide the exact position on the website, the position will be automatically placed in the configuration file ;)

(At least i don't remember putting my coordinates into that file)

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 28000
Re: MLAT
« Reply #3 on: March 27, 2019, 06:15:18 PM »
Its new and has not been announced officially yet.  The X-Range 2 and X-Range, maybe other receivers as well but I don't know, are getting new firmware installed for MLAT capability.  Once they all have their firmware updated an email will be sent to all feeders asking them where necessary to update their Pi and/or to update their exact lat/lon to enable MLAT across the board

Alan
« Last Edit: March 27, 2019, 06:17:46 PM by Runway 31 »

ea2ip

  • New Member
  • *
  • Posts: 5
    • Station: EXTRPI000695
Re: MLAT
« Reply #4 on: March 27, 2019, 06:49:35 PM »
(Used actual values in place of xxxxxxxxxxxx, xx.xxxxxx, yy.yyyyyy, zzz (antenna height in meters)

Antenna height from ground or sea level?


abcd567

  • Sr. Member
  • ****
  • Posts: 260
  • CYYZ - Toronto
Re: MLAT
« Reply #5 on: March 27, 2019, 06:56:44 PM »
(Used actual values in place of xxxxxxxxxxxx, xx.xxxxxx, yy.yyyyyy, zzz (antenna height in meters)

Antenna height from ground or sea level?
Antenna Height Above Sea Level.
Sorry forgot to write in last post, will correct now.

MDA

  • New Member
  • *
  • Posts: 12
Re: MLAT
« Reply #6 on: March 27, 2019, 08:20:35 PM »
First in neighborhood :-)

ea2ip

  • New Member
  • *
  • Posts: 5
    • Station: EXTRPI000695
Re: MLAT
« Reply #7 on: March 27, 2019, 09:43:18 PM »
Not problem, working


wiedehopf

  • Jr. Member
  • **
  • Posts: 54
Re: MLAT
« Reply #8 on: March 30, 2019, 05:36:55 PM »
We have liftoff, MLAT is working :)

Note that per default the MLAT results from the rbfeeder MLAT are not visible in the local dump1090 map.

Hopefully when the feature is stable the feeder will have an option to enable forwarding the results to the local dump1090.


Aerotower

  • Hero Member
  • *****
  • Posts: 503
Re: MLAT
« Reply #9 on: March 31, 2019, 09:30:26 AM »
Here you see that map?

thanks

wiedehopf

  • Jr. Member
  • **
  • Posts: 54
Re: MLAT
« Reply #10 on: March 31, 2019, 10:12:15 AM »
That's the dump1090-fa webinterface with the wikipedia map tiles.

The layers.js can be modified to accept different tiles:
https://github.com/wiedehopf/dev-webview/blob/master/layers.js


But as i said those MLAT results are currently not visible.

If you have a Raspberry Pi getting that map shouldn't be too complicated.

Do the radarbox and xrange offer beast or AVR data via TCP?
It's not too hard to run a dump1090-fa in net-only mode and display beast data from the web:
https://github.com/wiedehopf/combine1090#combine1090

If it is AVR and not beast you will have to modify the target port.
« Last Edit: March 31, 2019, 10:16:56 AM by wiedehopf »

neroon79

  • Hero Member
  • *****
  • Posts: 4657
Re: MLAT
« Reply #11 on: April 19, 2019, 03:10:22 PM »
If trying to install mlat-client im getting the following:

Some packages could not be installed. That may mean that
You have requested an impossible situation or if you have the
Unstable distribution still use some required packages
have not been created or have not yet left Incoming.
The following information may help you to resolve the situation:

The following packages have unmet dependencies:
  mlat-client: Depends on: python3 (> = 3.5 ~) but 3.4.2-2 should be installed
                Depends on: python3.5: any is not installable
E: Problems can not be corrected, you have retained defective packages.

Ingo
Greetings from northern Germany, Ingo
11.75nm ESE of EDDV

SW: ANRB v5.00.072/6.01.001 on WIN10 64Bit Pro&Home
HW:
Ant.: DPD Productions ADS-B Vertical Outdoor Base Antenna
AMP: Kuhne electr. KU LNA 1090 A TM
Cable: 25m of ECOFLEX 15+
NB: Asus P53E 24/7 op.
PC: 28"4K + 24" Monitor
AirSpy mini @RPi3

wiedehopf

  • Jr. Member
  • **
  • Posts: 54
Re: MLAT
« Reply #12 on: April 19, 2019, 03:54:20 PM »
Run
sudo apt-get update
sudo apt-get upgrade

If that doesn't help you might be on Raspbian Jessie and need an upgrade to Stretch.

Depending on which sd-card image you started from that isn't too hard.

flygpagen

  • New Member
  • *
  • Posts: 8
Re: MLAT
« Reply #13 on: April 19, 2019, 05:50:55 PM »
Hello there,

I put up a new antenna on the roof today, and then went and enabled MLAT on my Pi according to the instructions above. However I suspect that something is wrong, seeing that the coverage has expanded all the way to GB (the antenna is no way that good). Also MLAT does not show on the station as your examples in this thread.
https://www.radarbox24.com/stations/EXTRPI001593

Will return to the field and do some error probing but ideas are welcome...

Runway 31

  • Moderator
  • Hero Member
  • *****
  • Posts: 28000
Re: MLAT
« Reply #14 on: April 19, 2019, 06:35:41 PM »
It looks like the feeder is updated correctly as you are showing the correct firmware version.  However now edit your location with the exact lat/lon in decimal then save.  Once that's done you should show MLAT active,

The spurious coverage shown over to the UK will wear off over the next week so I wouldn't bother with it

Alan