1-800-401-2474 | support@airnavsystems.com
Forum| About| Support| Contact
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Unable to install RB24 on my RPi  (Read 3226 times)

0 Members and 1 Guest are viewing this topic.

abcd567

  • Full Member
  • ***
  • Posts: 103
  • CYYZ - Toronto
Re: Unable to install RB24 on my RPi
« Reply #15 on: May 08, 2017, 01:26:12 pm »
Hi again abcd567, I wonder if you noticed I edited my last post with updated information after I tried your suggestion ?

Thanks

John
No, I did not see your message after you edited it. Now I saw it.

Which Operating System are you using? Is it Raspbian Jessie or Wheezy or something else?

May be it is an old version which is causing the issue. I have Pi model2, and Orange Pi PC. On Pi model2 I have latest Piaware image 3.5 which is actually Raspbian Jessie latest version in April 2017. On Orange Pi PC I have installed Armbian 2.5, which is actually Raspbian Jessie image, again in April 2017. On both these operating systems the installation of rbfeeder was trouble free.

In case of an old version, give following commands,, and then try to install rbfeeder again.
Code: [Select]
sudo apt-get update
sudo apt-get upgrade
« Last Edit: May 08, 2017, 01:41:34 pm by abcd567 »

Millsey

  • New Member
  • *
  • Posts: 7
Re: Unable to install RB24 on my RPi
« Reply #16 on: May 08, 2017, 02:30:07 pm »

In case of an old version, give following commands,, and then try to install rbfeeder again.
Code: [Select]
sudo apt-get update
sudo apt-get upgrade

To be honest I cannot remember the version as I set up this feeder in my shed a couple of years ago !! I have a spare SD card image that I have been trying all this on, so I'll see what happens next with the above commands. This will have to wait now as I will be away tonight, but thanks for your suggestion.  Will report back in about a week.

John

abcd567

  • Full Member
  • ***
  • Posts: 103
  • CYYZ - Toronto
Re: Unable to install RB24 on my RPi
« Reply #17 on: May 08, 2017, 04:12:59 pm »
To be honest I cannot remember the version as I set up this feeder in my shed a couple of years ago !! I have a spare SD card image that I have been trying all this on, so I'll see what happens next with the above commands. This will have to wait now as I will be away tonight, but thanks for your suggestion.  Will report back in about a week.

John

If trying "apt-get update" and "apt-get upgrade" dont solve the problem, try this one also:
Code: [Select]
sudo apt-get dist-upgrade

If all above fails, then the headache-free way is to format the microSD card and make a fresh install using latest versions of OS and all other software.

By the way I just now checked my Pi B+ which has Raspbian Jessie and dump1090-mutability, and rbfeeder works ok with it:

« Last Edit: May 08, 2017, 04:28:38 pm by abcd567 »

anorak

  • Hero Member
  • *****
  • Posts: 880
  • support The Devon Air Ambulance Trust
Re: Unable to install RB24 on my RPi
« Reply #18 on: May 08, 2017, 05:41:20 pm »
Done that, hope it helps.
Dave
Dave. Exmoor, North Devon.

abcd567

  • Full Member
  • ***
  • Posts: 103
  • CYYZ - Toronto
Re: Unable to install RB24 on my RPi
« Reply #19 on: May 08, 2017, 07:54:31 pm »
Done that, hope it helps.
Dave
These settings are perfect if you already have a working version of dump1090 or dump1090-fa, or dump1090-mutabilty.

The value of key is blank. If it is there, but you removed it from screenshot for sevurity reasons, it is ok.

In case the value of key is missing in the file rbfeeder.ini, you have to first get the key. This is an automatic process, and rbfeeder will get it for you and add to file rbfeeder.ini. Just give the following command and output will display the key and connection to server established, and messages being sent to FR24.
Code: [Select]
sudo rbfeeder

Press Ctrl+c to stop the process, and reboot the pi, then check status

Code: [Select]
sudo reboot
#After reboot
sudo systemctl status rbfeeder -l
The above command will show if your rbfeeder is running ok or not.

If you want to see the key, give following command
Code: [Select]
sudo rbfeeder --showkey
« Last Edit: May 08, 2017, 08:22:06 pm by abcd567 »

anorak

  • Hero Member
  • *****
  • Posts: 880
  • support The Devon Air Ambulance Trust
Re: Unable to install RB24 on my RPi
« Reply #20 on: May 08, 2017, 09:49:29 pm »
I don`t appear to have dump 1090 and get;
can`t connect to external source (127.0.0.1:3000
Is it possible to install dump1090 now or would a clean total install be better?
Hope you have a lot of patience, Dave ;-)
Dave. Exmoor, North Devon.

abcd567

  • Full Member
  • ***
  • Posts: 103
  • CYYZ - Toronto
Re: Unable to install RB24 on my RPi
« Reply #21 on: May 08, 2017, 10:56:44 pm »
I don`t appear to have dump 1090 and get;
can`t connect to external source (127.0.0.1:3000
Is it possible to install dump1090 now or would a clean total install be better?
Hope you have a lot of patience, Dave ;-)

CASE (1): Wrong port number
The correct port number for dump1090 is 30005 but the port number mentioned in your last message is 3000 (127.0.0.1:3000). Is this a typo or is it actually 3000 in rbfeeder.ini file? If it is actually 3000, then edit the file and correct the port number to 30005. After saving changes, restart rbfeeder or reboot the Pi

Code: [Select]
#Open configuration file (located at /etc/rbfeeder.ini)

sudo nano /etc/rbfeeder.ini

#Change option port to 30005.

#After making changes, press Ctrl+o (save) and then Ctrl+x (close the file and exit the nano editor)

#Restart rbfeeder
sudo systemctl restart rbfeeder
#OR
sudo reboot
#After restart or reboot, check status
sudo systemctl status rbfeeder -l


CASE (2): dump1090 was not pre-installed
If the port number in file /etc/rbfeeder.ini is 30005, then you dont seem to have dump1090. In this case, no need to install dump1090 as during installation, the rbfeeder checks for dump1090, and if not found, will install its built-in decoder. In this case the settings in rbfeeder.ini file should be as below:

Method 1

Code: [Select]
#Open configuration file (located at /etc/rbfeeder.ini) and change option "network_mode" to "false" under "[client]" section.

sudo nano /etc/rbfeeder.ini

#Change option "network_mode" to "false" under "[client]" section.

#After making changes, press Ctrl+o (save) and then Ctrl+x (close the file and exit the nano editor)

#Restart rbfeeder
sudo systemctl restart rbfeeder
#OR
sudo reboot

#After restart or reboot, check status
sudo systemctl status rbfeeder -l




Method 2

Code: [Select]
#Simply give this command
sudo rbfeeder --set-network-mode off --no-start

#Restart rbfeeder
sudo systemctl restart rbfeeder
#OR
sudo reboot

#After restart or reboot, check status
sudo systemctl status rbfeeder -l

« Last Edit: May 08, 2017, 11:37:50 pm by abcd567 »

anorak

  • Hero Member
  • *****
  • Posts: 880
  • support The Devon Air Ambulance Trust
Re: Unable to install RB24 on my RPi
« Reply #22 on: May 09, 2017, 12:21:29 pm »
Hi, followed the instructions and got the set up right but still wont start, get
rbfeeder.service start request repeated too quickly, refusing to start
Failed to start RBFeeder.service
Unit rbfeeder. service entered failed state.
( Beginning to feel like John Cleese.....I`m going to give you a darn good thrashing)
Dave.
Dave. Exmoor, North Devon.

abcd567

  • Full Member
  • ***
  • Posts: 103
  • CYYZ - Toronto
Re: Unable to install RB24 on my RPi
« Reply #23 on: May 09, 2017, 04:07:39 pm »
Hi, followed the instructions and got the set up right but still wont start, get
rbfeeder.service start request repeated too quickly, refusing to start
Failed to start RBFeeder.service
Unit rbfeeder. service entered failed state.
( Beginning to feel like John Cleese.....I`m going to give you a darn good thrashing)
Dave.

FIRST TRY REBOOT
Code: [Select]
sudo reboot

#After Pi reboots, check status of rbfeeder
sudo systemctl status rbfeeder -l


If even after reboot rbfeeder fails, RE-INSTALL rbfeeder as follows:

STEP-1:
#SAVE the sharing key by copying it from file /etc/rbfeeder.ini and pasting the key in a text file in your desktop/laptop and save the text file
Code: [Select]
cat /etc/rbfeeder.ini

[client]
network_mode                   = true
log_file                       = /var/log/rbfeeder.log
key                            = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
[network]
mode                           = beast
external_port                  = 30005
external_host                  = 127.0.0.1

#Alternative way to find the sharing key
Code: [Select]
sudo rbfeeder --showkey

Sharing key: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
You can link this sharing key to your account at http://www.radarbox24.com
Configuration file: /etc/rbfeeder.ini


STEP-2:
#Remove & Purge Existing RBfeeder
Code: [Select]
sudo systemctl stop rbfeeder
sudo dpkg --remove rbfeeder
sudo dpkg --purge rbfeeder

STEP-3:
#Find left-over files & folders
Code: [Select]
sudo find / -name rbfeede*

/var/log/rbfeeder.log
/var/cache/apt/archives/rbfeeder_0.1.0-20170414183602_armhf.deb

STEP-4:
#Delete leftover files & folders manually
Code: [Select]
sudo rm -rf /var/log/rbfeeder.log
sudo rm -rf /var/cache/apt/archives/rbfeeder_0.1.0-20170414183602_armhf.deb

NOTE: Above left-over files list is from the installation of an earlier version of RB Feeder, and with dump1090 pre-installed. Your file list may be different, and longer. Use the file list displayed by your "sudo find / -name rbfeede*" command. Left-over files list in STEP-3 & STEP-4 are given only for guidance

STEP-5:
#Install rbfeeder
Code: [Select]
sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"

STEP-6:
#Set key
Code: [Select]
sudo rbfeeder --no-start --setkey xxxxxxxxxxxxxxxxxxxxxxxxx

STEP-7:
#Check key is set correctly
Code: [Select]
sudo rbfeeder --showkey

Sharing key: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
You can link this sharing key to your account at http://www.radarbox24.com
Configuration file: /etc/rbfeeder.ini


STEP-8:
#If you dont have any version of dump1090 pre-installed and want to use rbfeeder's integral decoder, make network-mode off
#If you already have dump1090 pre-installed, skip this step.
Code: [Select]
sudo rbfeeder --set-network-mode off --no-start

STEP-9:
#Start rbfeeder and then check status
Code: [Select]
sudo systemctl restart rbfeeder

sudo systemctl status rbfeeder -l
« Last Edit: May 09, 2017, 06:07:16 pm by abcd567 »

anorak

  • Hero Member
  • *****
  • Posts: 880
  • support The Devon Air Ambulance Trust
Re: Unable to install RB24 on my RPi
« Reply #24 on: May 11, 2017, 10:04:38 am »
Morning a, still getting that same message. Think I will reformat the card and do a complete reinstall, after a long sit down in a dark room.
Thanks, Dave.
Dave. Exmoor, North Devon.

anorak

  • Hero Member
  • *****
  • Posts: 880
  • support The Devon Air Ambulance Trust
Re: Unable to install RB24 on my RPi
« Reply #25 on: May 12, 2017, 11:27:37 am »
Completed reinstall of;
1)FR24 and online
2) RB24 and still get;
pi@raspberrypi:~ $ sudo systemctl status rbfeeder -l
● rbfeeder.service - RBFeeder Service
   Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled)
   Active: failed (Result: start-limit) since Fri 2017-05-12 12:23:02 BST; 48s ago
  Process: 2394 ExecStop=/bin/kill -TERM $MAINPID (code=exited, status=1/FAILURE)
  Process: 2389 ExecStart=/usr/bin/rbfeeder (code=exited, status=1/FAILURE)
 Main PID: 2389 (code=exited, status=1/FAILURE)

May 12 12:23:02 raspberrypi systemd[1]: Unit rbfeeder.service entered failed state.
May 12 12:23:02 raspberrypi kill[2394]: -h, --help     display this help and exit
May 12 12:23:02 raspberrypi kill[2394]: -V, --version  output version information and exit
May 12 12:23:02 raspberrypi kill[2394]: For more details see kill(1).
May 12 12:23:02 raspberrypi systemd[1]: rbfeeder.service holdoff time over, scheduling restart.
May 12 12:23:02 raspberrypi systemd[1]: Stopping RBFeeder Service...
May 12 12:23:02 raspberrypi systemd[1]: Starting RBFeeder Service...
May 12 12:23:02 raspberrypi systemd[1]: rbfeeder.service start request repeated too quickly, refusing to start.
May 12 12:23:02 raspberrypi systemd[1]: Failed to start RBFeeder Service.
May 12 12:23:02 raspberrypi systemd[1]: Unit rbfeeder.service entered failed state.
Flogging dead horse comes to mind.
Dave.
Dave. Exmoor, North Devon.

abcd567

  • Full Member
  • ***
  • Posts: 103
  • CYYZ - Toronto
Re: Unable to install RB24 on my RPi
« Reply #26 on: May 12, 2017, 02:30:16 pm »
@anorak:
First REBOOT, then check status of rbfeeder

Code: [Select]
sudo reboot
sudo systemctl status rbfeeder -l

anorak

  • Hero Member
  • *****
  • Posts: 880
  • support The Devon Air Ambulance Trust
Re: Unable to install RB24 on my RPi
« Reply #27 on: May 12, 2017, 03:30:37 pm »
pi@raspberrypi:~ $ sudo systemctl status rbfeeder -l
● rbfeeder.service - RBFeeder Service
   Loaded: loaded (/lib/systemd/system/rbfeeder.service; enabled)
   Active: failed (Result: start-limit) since Fri 2017-05-12 16:28:03 BST; 1min 44s ago
  Process: 799 ExecStop=/bin/kill -TERM $MAINPID (code=exited, status=1/FAILURE)
  Process: 774 ExecStart=/usr/bin/rbfeeder (code=exited, status=1/FAILURE)
 Main PID: 774 (code=exited, status=1/FAILURE)

May 12 16:28:03 raspberrypi kill[799]: -<signal>, -s, --signal <signal>
May 12 16:28:03 raspberrypi kill[799]: specify the <signal> to be sent
May 12 16:28:03 raspberrypi kill[799]: -l, --list=[<signal>]  list all signal names, or convert one to a name
May 12 16:28:03 raspberrypi kill[799]: -L, --table            list all signal names in a nice table
May 12 16:28:03 raspberrypi kill[799]: -h, --help     display this help and exit
May 12 16:28:03 raspberrypi kill[799]: -V, --version  output version information and exit
May 12 16:28:03 raspberrypi kill[799]: For more details see kill(1).
May 12 16:28:03 raspberrypi systemd[1]: rbfeeder.service: control process exited, code=exited status=1
May 12 16:28:03 raspberrypi systemd[1]: Unit rbfeeder.service entered failed state.
May 12 16:28:03 raspberrypi systemd[1]: rbfeeder.service holdoff time over, scheduling restart.
May 12 16:28:03 raspberrypi systemd[1]: Stopping RBFeeder Service...
May 12 16:28:03 raspberrypi systemd[1]: Starting RBFeeder Service...
May 12 16:28:03 raspberrypi systemd[1]: rbfeeder.service start request repeated too quickly, refusing to start.
May 12 16:28:03 raspberrypi systemd[1]: Failed to start RBFeeder Service.
May 12 16:28:03 raspberrypi systemd[1]: Unit rbfeeder.service entered failed state.
pi@raspberrypi:~ $
Dave. Exmoor, North Devon.

abcd567

  • Full Member
  • ***
  • Posts: 103
  • CYYZ - Toronto
Re: Unable to install RB24 on my RPi
« Reply #28 on: May 12, 2017, 05:45:20 pm »
@anorak:

The failure of RB Feeder seems to be caused by conflict between FR24 feeder and RB Feeder.
This conflict is due to competition between two feeders to grab the dvb-t dongle.
Both these feeders have integral decoder and both these decoders try to grab the dvb-t dongle. The one which grabs first, works ok, other fails.

To overcome this situation, a separate decoder such as dump1090 should be installed, and the built-in decoders of both RB24 & FR24 feeders disabled and prevented from grabing dvb-t by running both feeders in network mode. In network mode, the integral decoders of two feeders will not grab & use the dvb-t dongle. Only dump1090 will grab the dvb-t dongle, and both RB24 & FR24 feeders will use dump1090's output.

1) Format microSD Card
2) Download Latest Raspbian Jessie image from www.raspberrypi.org/downloads
3) Write Raspbian Jessie image to microSD card
4) Install either dump1090, or dump1090-mutability, or dump1090-fa
NOTE:
It is important to install dump1090 BEFORE installing any data feeders to have a trouble free install

5) Install RB Feeder, and configure it to network mode as detailed below
6) Install FR24 feeder and configure it to network mode as detailed below


Settings of RB24 feeder when using a separate dump1090

Code: [Select]
sudo rbfeeder  --no-start --set-network-mode on
sudo rbfeeder  --no-start --set-network-host 127.0.0.1
sudo rbfeeder  --no-start --set-network-port 30005
sudo rbfeeder  --no-start --set-network-protocol beast


#Now check the file rbfeeder.ini to make sure correct settings have been entered and saved.

Code: [Select]
cat /etc/rbfeeder.ini

#Above command should show settings like below:

[client]
network_mode                   = true
log_file                       = /var/log/rbfeeder.log
key                            = xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx


[network]
mode                           = beast
external_port                  = 30005
external_host                  = 127.0.0.1


#If settings are not as above, these can be modified manually by editing the file rbfeeder.ini
Code: [Select]
sudo nano /etc/rbfeeder.ini

#After edit Ctrl+o (Save File) and then Ctrl+x (Exit the editor)

Finally restart Pi for settings to take effect.
Code: [Select]
#Restart PI
sudo reboot


Settings of FR24 feeder when using a separate dump1090

The FR24 Feeder can be configured on the page http://<IP of RPi>:8754/settings.html
The "Receiver" and "Host/IP" setting should be:

Receiver: ModeS Beast(TCP)
Host/IP: 127.0.0.1:30005

OR

Receiver: AVR(TCP)
Host/IP: 127.0.0.1:30002

Click "Save" button on bottom right of the settings page, and then click "Restart" button also at bottom-right of page
« Last Edit: May 12, 2017, 06:07:21 pm by abcd567 »

anorak

  • Hero Member
  • *****
  • Posts: 880
  • support The Devon Air Ambulance Trust
Re: Unable to install RB24 on my RPi
« Reply #29 on: May 16, 2017, 06:21:32 pm »
SSShhhh, 24 hours now and all working!
Don`t want to tempt fate, but thanks very much.
Dave.
Dave. Exmoor, North Devon.