1-800-401-2474 | support@airnavsystems.com
Forum| About| Support| Contact
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Unable to install RB24 on my RPi  (Read 3235 times)

0 Members and 1 Guest are viewing this topic.

Millsey

  • New Member
  • *
  • Posts: 7
Unable to install RB24 on my RPi
« on: May 06, 2017, 04:56:48 pm »
I tried to install RB24 to an existing RPi running Dump1090 which failed. I sent a request for help via the contact page and then to support@radarbox24.com. I got an automatic reply on May 1st, but have heard nothing since. If I try to login on the link provided all it says is that my email is already taken ?

Getting a bit confused as to why it is not possible to get an answer or login when I can here ?
John

Runway 31

  • Database Updaters
  • Hero Member
  • *****
  • Posts: 24050
Re: Unable to install RB24 on my RPi
« Reply #1 on: May 06, 2017, 05:39:53 pm »
I presume that you followed https://www.radarbox24.com/raspberry-pi  and https://www.radarbox24.com/blog/radarbox24-raspberry-pi-client

I will contact support and ask that they contact you as they don't look in here very often

Alan
« Last Edit: May 06, 2017, 05:43:59 pm by Runway 31 »

anorak

  • Hero Member
  • *****
  • Posts: 880
  • support The Devon Air Ambulance Trust
Re: Unable to install RB24 on my RPi
« Reply #2 on: May 06, 2017, 06:29:55 pm »
Could I suggest that we keep Raspberry issues to the thread that is running.
http://www.airnavsystems.com/forum/index.php?topic=8767.0
Dave.
Dave. Exmoor, North Devon.

Runway 31

  • Database Updaters
  • Hero Member
  • *****
  • Posts: 24050
Re: Unable to install RB24 on my RPi
« Reply #3 on: May 06, 2017, 09:09:02 pm »
Thats 3 or 4 running now Dave

Alan

Millsey

  • New Member
  • *
  • Posts: 7
Re: Unable to install RB24 on my RPi
« Reply #4 on: May 07, 2017, 07:46:09 am »
Thanks Alan, my ticket number is 8254 btw. Yes I followed instructions, but got this message at the end:

The following packages have unmet dependencies:
rbfeeder : Depends: libc6 (>= 2.17) but 2.13-38+rpi2+deb7u3 is to be installed
            Depends: librtlsdr0 but it is not installable
            Depends: systemd but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
bash: line 24: systemctl: command not found
bash: line 28: systemctl: command not found

My existing system is still running fine feeding a private VRS web site with data. I didn't post in the RPi3 thread as mine is a RPi2, and being new I guess I should have looked further at the forum first, sorry.

John

Runway 31

  • Database Updaters
  • Hero Member
  • *****
  • Posts: 24050
Re: Unable to install RB24 on my RPi
« Reply #5 on: May 07, 2017, 08:18:14 am »
Sorry means nothing to me John

I have emailed support and asked them to contact you

Alan

Millsey

  • New Member
  • *
  • Posts: 7
Re: Unable to install RB24 on my RPi
« Reply #6 on: May 07, 2017, 10:00:56 am »
Me neither Alan,

Thanks

John

abcd567

  • Full Member
  • ***
  • Posts: 103
  • CYYZ - Toronto
Re: Unable to install RB24 on my RPi
« Reply #7 on: May 07, 2017, 03:01:14 pm »
Try following:

Code: [Select]
sudo dpkg --configure -a
Code: [Select]
sudo apt-get install -f
Then try installation again

Code: [Select]
sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"
« Last Edit: May 07, 2017, 03:12:36 pm by abcd567 »

anorak

  • Hero Member
  • *****
  • Posts: 880
  • support The Devon Air Ambulance Trust
Re: Unable to install RB24 on my RPi
« Reply #8 on: May 07, 2017, 04:32:42 pm »
Hi a, my set up keeps going offline after a few minutes and I`ve no idea why. Running a NooElec dongle feeding another site that seems to be working fine, laptop getting tired so want to feed 24/7 via the Raspberry.
Cheers, Dave.
Dave. Exmoor, North Devon.

abcd567

  • Full Member
  • ***
  • Posts: 103
  • CYYZ - Toronto
Re: Unable to install RB24 on my RPi
« Reply #9 on: May 07, 2017, 05:37:19 pm »
Hi a, my set up keeps going offline after a few minutes and I`ve no idea why. Running a NooElec dongle feeding another site that seems to be working fine, laptop getting tired so want to feed 24/7 via the Raspberry.
Cheers, Dave.

1) Give this command in SSH console:
Code: [Select]
cat /etc/rbfeeder.ini
2) Post output of above command in this thread.
Note: remove you sharing key before you submit the post.


Runway 31

  • Database Updaters
  • Hero Member
  • *****
  • Posts: 24050
Re: Unable to install RB24 on my RPi
« Reply #10 on: May 07, 2017, 05:43:15 pm »
Thanks for your advice ABD567 I have no idea on this

Alan

Millsey

  • New Member
  • *
  • Posts: 7
Re: Unable to install RB24 on my RPi
« Reply #11 on: May 07, 2017, 05:50:01 pm »
Try following:

Code: [Select]
sudo dpkg --configure -a
Code: [Select]
sudo apt-get install -f
Then try installation again

Code: [Select]
sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"

Thanks for the info abcd567, I've just tried your suggestions but got this message after running the first two lines:
pi@raspberrypi ~ $ sudo dpkg --configure -a
pi@raspberrypi ~ $ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 191 not upgraded.
Same message after running the install line as I posted earlier
Know you from FR24 Forum I believe ?

John
« Last Edit: May 07, 2017, 06:42:28 pm by Millsey »

abcd567

  • Full Member
  • ***
  • Posts: 103
  • CYYZ - Toronto
Re: Unable to install RB24 on my RPi
« Reply #12 on: May 07, 2017, 06:31:45 pm »
Thanks for your advice ABD567 I have no idea on this

Alan

When you give cat /etc/rbfeeder.ini command, the contents of file rbfeeder.ini will be displayed. Copy that output from SSH window, and paste in your reply to this thread.

For your guidance, I am posting below the output of the cat /etc/rbfeeder.ini for my RPi. (I have replaced my actual sharing key by xxxxxxxxxxxxxxx ).

This is the setting which works ok for me, as before installing rbfeeder, I already had some version of dump1090 running for feeding other sites.

Code: [Select]
cat /etc/rbfeeder.ini

[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key= xxxxxxxxxxxxxxxxxxxxxxxxxx


[network]
mode=beast
external_port=30005
external_host=127.0.0.1



abcd567

  • Full Member
  • ***
  • Posts: 103
  • CYYZ - Toronto
Re: Unable to install RB24 on my RPi
« Reply #13 on: May 07, 2017, 08:21:12 pm »
I had dump1090-fa already installed before I installed RB Feeder


Millsey

  • New Member
  • *
  • Posts: 7
Re: Unable to install RB24 on my RPi
« Reply #14 on: May 08, 2017, 10:47:45 am »
Hi again abcd567, I wonder if you noticed I edited my last post with updated information after I tried your suggestion ?

Thanks

John