anything
1-800-401-2474 | support@airnavsystems.com
Forum| About| Support| Contact
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 


Author Topic: Registrations not appearing on Interface  (Read 1001 times)

0 Members and 1 Guest are viewing this topic.

Geot

  • Jr. Member
  • **
  • Posts: 60
Registrations not appearing on Interface
« on: August 16, 2017, 01:24:53 am »
I have just replaced Laptops, new one with Windows 10 Pro. I installed the old disk and then downloaded V600002 to get V6.00.001 on my  system. I  have updated Database Explorer.
Some registrations do not get written to the screen, if I right-click on the Mode-S it shows up as being in Explorer. The aircraft appears on the Map using the Mode-S to identify. In My Log, using Populate fills in all the missing details.

Occurs on approximately 10% of the trackings, all others look normal.

Drivers show as V2.8.30. I downloaded the 20161222 drivers. I do not know if they are the same, when I try to force the Device Manager to use 21061222 it says that the system already has the latest drivers loaded.

Any ideas?
GeorgeT

neroon79

  • Hero Member
  • *****
  • Posts: 4389
Re: Registrations not appearing on Interface
« Reply #1 on: August 16, 2017, 02:23:34 am »
Hello George,

the drivers are necessary for communication between the hardware and the operating system. It tells the operating system how to talk with the hardware. As you already have aircraft on screen or in the list the drivers are working OK.

The problem you are describing is typical for what happens if ANRB program is installed to Program files and not to something like C:\RadarBox. 

Reason(as far as I know): ANRB.EXE is not able to cope with the virtual memory provided by Win10. It always look's for the database file within the installation folder. Unfortunately WIN10 does not allow software to change files in program file section file this soft ware is running. But it makes a copy in "virtual memory", which is used  by ANRB.EXE as long as it is running. But on next start ANRB.EXE doesn't use the db file from virtual memory but from install path. So all changes are gone.

Only solution if installed in program files: uninstall software, remove all traces by using search to find them. re-install to C:\RadarBox.

Ingo
Greetings from northern Germany, Ingo
11.75nm ESE of EDDV

SW: ANRB v5.00.072/6.00.000 on WIN10 64Bit Pro&Home
HW:
Antenna: outside WiMo GP-1090
AMP: Kuhne electronic KU LNA 1090 A TM
Cable: 20m of ECOFLEX 15+
Asus P53E (BIZ-Notebook) 24/7 op.
Quad Core PC with 26"+24" Screen

Runway 31

  • Database Updaters
  • Hero Member
  • *****
  • Posts: 24029
Re: Registrations not appearing on Interface
« Reply #2 on: August 16, 2017, 07:40:52 am »
Hi George,

Yes as Ingo states it looks like you installed to program files instead of the recommended C:\Airnav or similar.  The Windows virtual store causes problems so the advice has always been not to install to there.  I would suggest that you uninstall including manually uninstalling any remnants left behind from the auto uninstall and reinstalling to C:\Airnav.  Failure to manually delete any remnants will cause issues especially with the updater.

You don't need to go to V6 which is only useful if you have a dongle, you can stay on V5 from here http://www.airnavsystems.com/download/ANRB/ANRB50072Setup.exe

You should thereafter have no problems.

Alan
« Last Edit: August 16, 2017, 07:43:11 am by Runway 31 »

Geot

  • Jr. Member
  • **
  • Posts: 60
Re: Registrations not appearing on Interface
« Reply #3 on: August 16, 2017, 12:41:38 pm »
Thanks for the suggestions, but that does not seem to be the solution as I did install to C\Air Nav. All was working OK on old system using Version 6 with RB Box, however I will probably completely remove all software and reinstall Version 5 to see if that makes a difference.

It is rather strange as on some lines all the other info appears i.e. Flight Number, Route but not the Registration.

GeorgeT

Runway 31

  • Database Updaters
  • Hero Member
  • *****
  • Posts: 24029
Re: Registrations not appearing on Interface
« Reply #4 on: August 16, 2017, 01:00:18 pm »
How many records do you have in your Aircraft table.  Populate connects to the server and downloads direct from it, have you downloaded the Navdata, todays download should give you around 253,995 records in the aircraft table. How many records do you have in your Aircraft table

Alan
« Last Edit: August 16, 2017, 03:19:05 pm by Runway 31 »

Geot

  • Jr. Member
  • **
  • Posts: 60
Re: Registrations not appearing on Interface
« Reply #5 on: August 16, 2017, 03:55:03 pm »
I have 253,803 in my Aircraft Table. It was downloaded a couple of days ago.

GeorgeT

Runway 31

  • Database Updaters
  • Hero Member
  • *****
  • Posts: 24029
Re: Registrations not appearing on Interface
« Reply #6 on: August 16, 2017, 04:30:01 pm »
No idea why this is happening to you then George.  You are running the software in C:\Airnav and are using the downloaded drivers and have a recent Navdata

My box is u/s with a defective USB port just now so I cannot check which driver version it shows but the Airnav stick shows V6.1.7600.16385 so it may be that you still have work to do with the drivers.  Can you try Control Panel/Unspecified to find your box.  Right click on it /Properties/Hardware/Properties/Change Settings/Driver/Update Driver/Browse my computer for driver software.  Does that allow you to Browse to where you unzipped the drivers?

Alan

Geot

  • Jr. Member
  • **
  • Posts: 60
Re: Registrations not appearing on Interface
« Reply #7 on: August 16, 2017, 05:04:52 pm »
When I go to Device Manager whether I select the search online for better drivers or force it to search on my local pc, (selecting ANRB -Drivers-201612220), from both I get the "Windows has determined that the best driver for this device is already installed". I cannot seem to force it to select the 20161222 file.

GeorgeT

Runway 31

  • Database Updaters
  • Hero Member
  • *****
  • Posts: 24029
Re: Registrations not appearing on Interface
« Reply #8 on: August 16, 2017, 05:09:23 pm »
Can you try running as Admin on start up

Other than that maybe support can help you George, I am out of ideas, no idea why it doesn't show all aircraft

Alan

Geot

  • Jr. Member
  • **
  • Posts: 60
Re: Registrations not appearing on Interface
« Reply #9 on: August 16, 2017, 05:12:10 pm »
Hi Alan, Further, I have just recently had a Global Express go up on test flight, RB displayed the registration. Now it is on it's way back and the Registration does not display this time! Although the Call Sign and Owner does. Thanks for all suggestions and effor, will try going back to version 5.

GeorgeT

Runway 31

  • Database Updaters
  • Hero Member
  • *****
  • Posts: 24029
Re: Registrations not appearing on Interface
« Reply #10 on: August 16, 2017, 05:32:25 pm »
Should be no problem with V6, plenty using on W10 with no problems like yours

Alan

Geot

  • Jr. Member
  • **
  • Posts: 60
Re: Registrations not appearing on Interface
« Reply #11 on: August 19, 2017, 07:56:16 pm »
Hi Alan, just to let you know that I am finally online and all working OK. After days of fights with drivers, upgrades, re-installs from disk and upgrades, working with Support. The solution was to un-install RB and install V.6.01.001 as a fresh install, direct download from the Air Nav website.

cheers
GeorgeT


Runway 31

  • Database Updaters
  • Hero Member
  • *****
  • Posts: 24029
Re: Registrations not appearing on Interface
« Reply #12 on: August 19, 2017, 08:08:19 pm »
Thanks for advising George,  I presumed that you had done a fresh install to begin with but good to know its working for you

Alan